[Boards: 3 / a / aco / adv / an / asp / b / biz / c / cgl / ck / cm / co / d / diy / e / fa / fit / g / gd / gif / h / hc / his / hm / hr / i / ic / int / jp / k / lgbt / lit / m / mlp / mu / n / news / o / out / p / po / pol / qa / qst / r / r9k / s / s4s / sci / soc / sp / t / tg / toy / trash / trv / tv / u / v / vg / vp / vr / w / wg / wsg / wsr / x / y ] [Search | Home]
4Archive logo
Things you hate in vidya thread
Images are sometimes not shown due to bandwidth/network limitations. Refreshing the page usually helps.

You are currently reading a thread in /v/ - Video Games

Thread replies: 517
Thread images: 221
File: Box of hate.jpg (91 KB, 900x300) Image search: [iqdb] [SauceNao] [Google]
Box of hate.jpg
91 KB, 900x300
Things you hate in vidya thread
File: 1436116442108.gif (832 KB, 150x250) Image search: [iqdb] [SauceNao] [Google]
832 KB, 150x250
>nothing happens
>alt-tab back into game
>black screen
>game's music still audible

For fuck's sake it's 2016.
File: sanc.png (29 KB, 324x283) Image search: [iqdb] [SauceNao] [Google]
29 KB, 324x283
>invisible walls
>alt tab
>the game crashes

>alt tab
>try to get back in
>it crashes
>Game crashes
File: 1452031493341.gif (2 MB, 320x180) Image search: [iqdb] [SauceNao] [Google]
2 MB, 320x180
>indivisible walls
fucking this
the epitome of laziness in game design
File: 0015 - rUHFbjL.jpg (81 KB, 500x500) Image search: [iqdb] [SauceNao] [Google]
0015 - rUHFbjL.jpg
81 KB, 500x500
>make alt+tab thread
>turns gay

that was a fun thread
>Situations that could have been avoided if the game didn't switch to scripted scene mode

But are random bushes you can't jump over or how every street just happens to have some cars that block you in really that much better?
File: Maya_real.jpg (15 KB, 200x300) Image search: [iqdb] [SauceNao] [Google]
15 KB, 200x300
whatever this thing is
>alt + tab out
>alt+tab back in
>game's colors get all fucked up
File: ok.png (150 KB, 474x525) Image search: [iqdb] [SauceNao] [Google]
150 KB, 474x525
>pile of rubble blocks the way
>the player character would easily be able to scale over the rubble or clear it by hand, but nu-uh, developer says you can't go there
File: angry.jpg (50 KB, 600x884) Image search: [iqdb] [SauceNao] [Google]
50 KB, 600x884
>Like three weak mooks
>We're outnumbered! Fall back!
>Exit game
File: 1452004679975.gif (2 MB, 275x154) Image search: [iqdb] [SauceNao] [Google]
2 MB, 275x154
>playing game
>hit a cutscene
>really need to pee
>press escape/pause
>skips cutscene
File: 1434631623313.png (77 KB, 500x500) Image search: [iqdb] [SauceNao] [Google]
77 KB, 500x500
>has 1920x1200
>it's just 1920x1080 with black bars
It's the current year come on
File: 1451542311911.jpg (54 KB, 500x577) Image search: [iqdb] [SauceNao] [Google]
54 KB, 500x577
>can't buy MP restores in shops
>switch-based dungeons
I prefer it to literally nothing stopping you from moving.
File: 1k24hf24lb4.jpg (154 KB, 1680x1050) Image search: [iqdb] [SauceNao] [Google]
154 KB, 1680x1050
>8:5 master race still isn't the standard
>can't switch party leader in jrpg during battle

for what purpose?
File: mad cat.webm (677 KB, 480x480) Image search: [iqdb] [SauceNao] [Google]
mad cat.webm
677 KB, 480x480
>get to select between several items or skills
>no description on what their stats are or what the fuck they do
File: 1389417567864.png (198 KB, 900x900) Image search: [iqdb] [SauceNao] [Google]
198 KB, 900x900
>he took madurai
the frozen flame?
>start game
>main menu is unresponsive
>game autodetects controller and refuses KB input until you unplug the controller

>lose a boss fight and have to restart the encounter
>encounter has long cutscene you can't skip

>reach final boss
>beat him
>go around for another 5 minutes
>game ends
>no new game+
>Can't rebind keys
>game is made for AZERTY
>People who press alt+tab instead of the windows key.
You all disgust me.
Fucking this, it annoys me to no end to see protagonist get captured by some mooks that he/she had just killed by dozens.
>an't alt-tab without crashing/glitching the game
>status effects almost never effective on enemies worth using them on
>can only save at save points instead of saving and quiting when you want
File: 1395199301762.gif (879 KB, 294x233) Image search: [iqdb] [SauceNao] [Google]
879 KB, 294x233
>unplugging the controller doesn't switch it to KB+M immediately
>need to re-launch the game for it to use the KB+M
File: 1399096710320.gif (1 MB, 240x180) Image search: [iqdb] [SauceNao] [Google]
1 MB, 240x180
>reward for 100%ing the game is an amazing new weapon and method of transportation
>Game takes another few minutes to load on startup to check for trophies/achievements and dlc
File: 1451401899480.jpg (33 KB, 500x500) Image search: [iqdb] [SauceNao] [Google]
33 KB, 500x500
>taking damage during an unskippable cutscene
File: 1450505068220.jpg (14 KB, 342x316) Image search: [iqdb] [SauceNao] [Google]
14 KB, 342x316
>Game has autodetected your settings and changed it to optimize performance
>1440x960 resolution, all settings on low, vsync on
Games that don't have a Borderless Windowed option.
>have to level up to defeat enemies

I hate almost every RPG
File: 1452260772269.jpg (13 KB, 208x208) Image search: [iqdb] [SauceNao] [Google]
13 KB, 208x208
>menus have to be navigated with keyboard buttons only - the mouse doesn't work
File: 0898 - R4kEFrx.png (119 KB, 635x493) Image search: [iqdb] [SauceNao] [Google]
0898 - R4kEFrx.png
119 KB, 635x493
>diablo 3
>finally reach an area with enemies so dense you can spam abilities non-stop
>it's a scripted area and tyrael flies in and smites them all dead after 5 seconds
>Hit enemy with weapon
>It flashes red
Admittedly i can't say i HATE this, but it's just a detail that annoys me for some reason.
File: 1451690382084.jpg (110 KB, 337x334) Image search: [iqdb] [SauceNao] [Google]
110 KB, 337x334
>game starts up in windowed mode
>switch to fullscreen
>framerate is shit until game is restarted
>game restarts in windowed mode
File: scout x2.png (354 KB, 495x539) Image search: [iqdb] [SauceNao] [Google]
scout x2.png
354 KB, 495x539
>Default crouch button: X
File: 1384341881369.jpg (76 KB, 310x235) Image search: [iqdb] [SauceNao] [Google]
76 KB, 310x235
>No new game plus

What the point of getting the best items and shit if you can only use them for 5 minutes.
>time limits
>what looks like a secret path/hidden area is actually the way you're supposed to proceed
>unskippable cutscenes
>motion blur
>turn based battles
File: 1446080150276.jpg (22 KB, 604x300) Image search: [iqdb] [SauceNao] [Google]
22 KB, 604x300
>beat the game on normal to unlock hard difficulty
>beat the game on hard to unlock insane difficulty

>Not disabling your windows key from the start
File: 1434758318144.jpg (4 KB, 140x160) Image search: [iqdb] [SauceNao] [Google]
4 KB, 140x160
>game accepts xbox controllers
>doesnt accept any other controller
>Yet there are so many rpg's that have low level runs, some still at lvl 1

Sounds like you are just a baddy and got mad at the whole genre for it lol
>alt-tab out
>windows is still using the retarded resolution that the game was using
>alt-tab back in
>game is now using the resolution that windows was using and now half the screen is cut off

Fucking Bethesda.
>have controller (unknowingly) plugged in, on the floor
>playing game with KB/M, something happens
>have a heart attack because the controller starts vibrating
File: 1428974249719.jpg (107 KB, 900x900) Image search: [iqdb] [SauceNao] [Google]
107 KB, 900x900
>initiating conversation requires two simultaneous inputs
>picking things up requires two simultaneous inputs
>combat requires two simultaneous inputs
>trading requires two simultaneous inputs
>basic interaction requires two simultaneous inputs
>saving the game takes longer than a millisecond when you're on an ssd
>has a dedicated "saving game please wait" menu"

Fuck you if your game does this.
>second game into trilogy
>run part one save into gaem with your boosted stats
>start new game as scrub, have to relearn everything

why the fuck does a soldier have to learn how to do ANYTHING? i understand the mechanics of character/skill development but ffs it's just fuckin stupid.
>load up ark
>controller VRRRs cause it has controller support for some god-awful reason
>no vibration control in options
>had to unplug controller
>Find a weapon
>It's the supposed personification of death
>All-powerful, all feared, said to win every battle
>Get a measly +2 to damage
And, for an added bonus
>Kill some random asshat
>He has a weapon that does even more damage
File: 1452040275442.png (72 KB, 678x866) Image search: [iqdb] [SauceNao] [Google]
72 KB, 678x866
>Only see the upper half of the boss
>He's not on the stage he's outside the boundary
Roll sold your shit.
File: 1451782641134.jpg (27 KB, 353x353) Image search: [iqdb] [SauceNao] [Google]
27 KB, 353x353
>have to save constantly in anticipation of game crashes
>game mocks you for saving too frequently
File: 1439826709140.jpg (48 KB, 533x496) Image search: [iqdb] [SauceNao] [Google]
48 KB, 533x496
>Hit a giant boss in the foot 30 times
>It dies
File: FUAAAARK.png (35 KB, 1017x728) Image search: [iqdb] [SauceNao] [Google]
35 KB, 1017x728
>reach crossroads
>2 of the 3 available paths are just a looong interconnected side-route

pic related. perfect rage fuel.
File: 1398818499155.jpg (13 KB, 239x256) Image search: [iqdb] [SauceNao] [Google]
13 KB, 239x256

>Playing Ark
>Usually leave my xbox 360 controlled plugged in on top of my computer tower
>Get hit
>Think my computer is about to fucking explode
File: 1448594119796.png (141 KB, 302x257) Image search: [iqdb] [SauceNao] [Google]
141 KB, 302x257
>menu is navigated with the arrow keys
>have to take your hand off the mouse/navigation keys to use menus
>game is notoriously buggy and has several sections that can become unwinnable
>you can only get the true ending if you beat it under a certain number of saves
>Beat hard mode to unlock very hard mode
>Beat very hard mode to unlock easy mode

Postal 2
File: 1432473419160.jpg (48 KB, 500x352) Image search: [iqdb] [SauceNao] [Google]
48 KB, 500x352
>get giganigga sword of +1gorillion damage
>can't use it until lvl 1337
>keep it in your inventory the entire time for when you are able to use it
>finally reach lvl 1337
>turns out you've been using the taxmaster sword of +500Gorillion damage for ages
>been wasting an inventory slot like a retard.
you got it
File: tiggered.jpg (6 KB, 172x225) Image search: [iqdb] [SauceNao] [Google]
6 KB, 172x225
>be wielding Ash'kandoriel, Tooth of the Old God
>new expac comes out
>first quest reward deals more damage
>early blizzard games
>Megaman Legends

File: 657657567.jpg (25 KB, 327x223) Image search: [iqdb] [SauceNao] [Google]
25 KB, 327x223
>find joke weapon that only does 1 damage
>throw it away
>later find out it would have been really useful in that ONE situation
File: 1452114223199.jpg (499 KB, 1000x1000) Image search: [iqdb] [SauceNao] [Google]
499 KB, 1000x1000
>Get shot
>Hit indicator doesn't show which direction
>Either that or it points in the opposite direction
I knew this would happen.
>Beat the hardest difficulty first
>Don't get reward for being Easy and Medium

Fucking bonus levels in Perfect Dark Arcade, also fuck Achievements that don't unlock the Beat Easy and Medium when you beat it on the Hard
File: 1377120939291.png (87 KB, 297x198) Image search: [iqdb] [SauceNao] [Google]
87 KB, 297x198
>joke weapon that does 1 dmg
>you have to use it to level it up
>it becomes the best weapon in the game
>Star Oceans 3 Metal Pipe, don't toss it! You have to beat bosses with it for trophies!
what abomination does this?
for real, either make a pit or a cliff or fucking lava. jesus.
File: ohshitnigger.jpg (18 KB, 366x380) Image search: [iqdb] [SauceNao] [Google]
18 KB, 366x380
>joke weapon does 1 damage
>can level it up
>spend hours grinding it
>it now does 2 damage
>adjust to default controls in first game
>sequel changes default controls even though nothing was added to warrant a control scheme change
>Game gives you one hundred different abilities, the vast majority of them are useless
>The most pointless has one situation where you have to use it and only it, a good several hours after you learn about it
>When you've gained a dozen improvements on it since
File: 1452248973745.jpg (80 KB, 604x603) Image search: [iqdb] [SauceNao] [Google]
80 KB, 604x603
>no "take all" button
>have to individually take everything
>upgrade joke weapon enough that it becomes useful

Autism pays off
File: 1384707352407.png (368 KB, 640x480) Image search: [iqdb] [SauceNao] [Google]
368 KB, 640x480
>alt-tab out
>windows is still using the retarded resolution that the game was using
>all your autistically arranged desktop icons have now been mashed onto the left side of the screen
playing the sequel to a game that ends off you being badass but in the next game they BS some reason for you to restart at level 1.
File: 1451987713197.gif (3 MB, 220x212) Image search: [iqdb] [SauceNao] [Google]
3 MB, 220x212
>Want to 100% a Game
>Achievement or Item that needs to be unlocked by Completing the game on Easy mode
>You don't get it if you do it Normal or Higher. You have to do it on Easy. Same for the other Difficulty Achievements/Items.
>Enemies have multiple vendor trash listed before viable drops.
>enemies drop trash items that are completely useless and only take up inventory space, forcing you to loot individually
File: CaveExplorer.jpg (60 KB, 607x300) Image search: [iqdb] [SauceNao] [Google]
60 KB, 607x300
Fucking Banjo-Tooie's swimming controls
You are a badass, it's just that all the new enemies are even more badass then the ones in the previous game and more then you. And it would be silly to start you off at lvl 100
>alt tab
>enemies drop trash items that have no use but take up a fuckton of inventory space
>there is that one sperg on the map who will pay slightly more than the average sale pirce for every piece of garbage you bring him

Who are you quoting
File: mad as fuck.png (155 KB, 296x405) Image search: [iqdb] [SauceNao] [Google]
mad as fuck.png
155 KB, 296x405
>Game has a long and unskippable cutscene right before a difficult boss fight
File: 1451185693668.jpg (47 KB, 650x366) Image search: [iqdb] [SauceNao] [Google]
47 KB, 650x366
>large open world
>no fast travel at all

Looking at you Dying Light
File: 9LC2z2a.png (64 KB, 180x182) Image search: [iqdb] [SauceNao] [Google]
64 KB, 180x182
>game has crafting system
>you can only make things to kill other things
File: sonic17.jpg (26 KB, 584x448) Image search: [iqdb] [SauceNao] [Google]
26 KB, 584x448
>beating the game on highest difficulty doesn't count for lower difficulty unlocks
>loading screen with character models, game title, and/or shitty "tips"
>postgame boss drops weapon that would only be useful against the postgame boss
>sidequests requiring you to do some shit like rest at a specific inn five times in a row
>mandatory party member the entire game
>party member that constantly leaves and returns at a lower level with shitty gear is required for a boss fight
>platformer has the character in the center of the screen at all times
>game of a specific genre poorly attempts to imitate or parody another genre for one level
>holding the attack button longer than a second makes you do a string of attacks
>no camera control
>game is completely normal until one section where it felt the need to use the platform's single gimmick
>accepting a quest lowers drop rates
>swimming controls are inverted but flying isn't
>can't flee from low level encounters
>"Remember to take a break! :)"
File: 1392336530013.png (9 KB, 468x147) Image search: [iqdb] [SauceNao] [Google]
9 KB, 468x147
>start game
>doing good
>windows minimizes the game
>game has now crashed
File: 1415441394220.gif (393 KB, 640x360) Image search: [iqdb] [SauceNao] [Google]
393 KB, 640x360
>company makes 4 shooters
>all of them have the exact same control scheme
>company makes a new shooter ip
>it acts pretty much like same 4 games they made before
>has no control scheme to make it like their other games
guess the game
File: ABSOLUTELY 2016.png (367 KB, 763x652) Image search: [iqdb] [SauceNao] [Google]
367 KB, 763x652
>Get amazing weapon near the end of the game
>can only use it in like final 2 missions
>no fucking NG+
The worst part is when you take this route and they don't even reward/compensate you for taking the route. Then you have to go to the next section low on resources.
>"Keep the current color scheme and don't ask me again"
>windows asks every time

>game designed around parkour and mobility
>putting in simple fast travel

That would ruin the whole point if you could just fast travel across the map. And there even is fast travel between Harran proper and Sector 0.
File: image.jpg (35 KB, 420x211) Image search: [iqdb] [SauceNao] [Google]
35 KB, 420x211
>hit indicator says the enemy attacked from the right
>now left
>now right again
>do a 180
>enemy was directly behind you the entire time

>eerie cave
>bright wide open corridor
>go into the cave
>collapses and can't go back
>only autosaves allowed
>annoying popup wants you to do something
>only options are "Yes" and "Later".
File: 1452184412998.jpg (75 KB, 479x439) Image search: [iqdb] [SauceNao] [Google]
75 KB, 479x439
>Not monitor switching option
Why is this not fucking standard by now?
That would defeat the whole point of the parkour in Dying Light though.
>big important fight coming up
>game minimizes because windows wants to tell you about win10 for the billionth time that day
>takes a minute to reopen it
File: 1425066919916.gif (1 MB, 300x188) Image search: [iqdb] [SauceNao] [Google]
1 MB, 300x188
are you rubes using windows 10 or something?
The thing I hate the most in vidya is this:

"Oh, we need to travel to this place, but that requires a ship or something and OH NO the captain is gone/map is missing/they won't take us so first we need to go do this completely irrelevant sidequest that serves no purpose other than to slow you down whether you like it or not!"
>get shot in the front
>all 4 indicators go off
File: 1424650638966.jpg (75 KB, 513x592) Image search: [iqdb] [SauceNao] [Google]
75 KB, 513x592
>First few Bosses always reward you with some item when you defeat them
>Establish that this is how the game gives you upgrades
>After a while Bosses give you nothing
>hard mode just cripples damage dealt and increases damage received

>minimizing or full-screening once the game has started makes it crash
No one, just like the anon I replied to and almost 100% of the people in the thread.

You happy now?

I just want a simple fast travel. I'm sick and tired of running to that damn fishing village.
File: 1452102797350.gif (2 MB, 320x240) Image search: [iqdb] [SauceNao] [Google]
2 MB, 320x240
>Statue effects are useless

No i'm using Windows 7

But it's pirated if it matters
File: 1452022305680.jpg (35 KB, 640x640) Image search: [iqdb] [SauceNao] [Google]
35 KB, 640x640
>59 Mhz
use GWX Control Panel
File: 1442227328131.jpg (32 KB, 604x604) Image search: [iqdb] [SauceNao] [Google]
32 KB, 604x604
>finish a boss fight without any trouble at all, still near full health and resources
>in the following cutscene you're at the mercy of the boss
>your character acts like he's exhausted and can't handle one more attack
well I too am using a pirated copy of windows 7 and it doesn't do any of that shit to me, ever. maybe you need to adjust your settings.
File: 1446746603967.jpg (271 KB, 1917x1079) Image search: [iqdb] [SauceNao] [Google]
271 KB, 1917x1079
>game presents an option with dealing with a quest
>do you want to be a goodie-two-shoes or literally worse than Hitler?
>choose evil route
>reward is shitty compared to the good route

Every fucking time
File: 1315707766828.jpg (12 KB, 267x181) Image search: [iqdb] [SauceNao] [Google]
12 KB, 267x181
>fullscreen mode
>game throws a fit trying to alt+tab

>windowed fullscreen mode
>game window resizes itself randomly
>can't manually resize it
>have to go through door to progress story
>it's locked from the inside
>door is clearly very weak
>player character is carrying knives, crowbars, shotguns, timed explosives
>end up having to go around half the town to find the key
File: 1451622123552.gif (161 KB, 395x408) Image search: [iqdb] [SauceNao] [Google]
161 KB, 395x408
>Game gives you dialogue options during a cutscene
>all the options are just slight variations of yes
File: 1407500161725.png (254 KB, 500x375) Image search: [iqdb] [SauceNao] [Google]
254 KB, 500x375
>one-time boss fight has a rare drop
>one-time boss fight has multiple bosses with rare drops
>the rare drops count toward 100% completion
File: Samarrow.jpg (31 KB, 300x348) Image search: [iqdb] [SauceNao] [Google]
31 KB, 300x348
>main menu
>two options and one is highlighted
>can't tell which is selected

>loading bars that fill almost the full way instantly and stick at 99% for ages

>spoilers in start up video

>loading screen isn't interactive

>no interactive credits

>can't skip credits for secret shit
>wait the whole way through

What really gets me going is in games with levelling up and stats, but the developers were so lazy that the only important stat is your level vs the enemies.
Like if you're 1 level lower you do less damage and if you're 10 levels lower you do almost no damage, even if your stats are the same.

Why even fucking have stats when the only one that matters is level? Shit is fucking lazy.
upgrading to Windows 10 actually fixed this issue for me...
what games do this?
File: hepler.jpg (11 KB, 500x300) Image search: [iqdb] [SauceNao] [Google]
11 KB, 500x300
>unskippable gameplay
File: 7ff.jpg (71 KB, 288x499) Image search: [iqdb] [SauceNao] [Google]
71 KB, 288x499
>>spoilers in start up video
>first time setup
>installing microsoft visual C++
>the last option is no
>the characters call you an asshole, and proceed as if you said yes anyway
>go to options menu
>shit load of options including a bunch of obscure ones I've never heard of before
>game doesn't tell you what any of those options do

Come the fuck on, I'm an accountant, not a computer programmer.
File: 1406356088916.jpg (129 KB, 791x1024) Image search: [iqdb] [SauceNao] [Google]
129 KB, 791x1024
>enter a new, giant open area
>entire area is covered in chest high walls or other forms of cover

Oh boy. Wonder what's going to happen now.
Playing Pillars right now. Legit wish this was an option

Most modern western RPGs, or games with RPG like stats in them.

Most recent I played that did it was Witcher 3.
>Trails of the Skies SC
>You retain your levels from FC, but enemies are at your level

>All monsters around the world got stronger
>Somehow the rest of the world isn't fucked by the giant onslaught of stronger monsters on the roads
File: spnegbab reaction.png (704 KB, 919x973) Image search: [iqdb] [SauceNao] [Google]
spnegbab reaction.png
704 KB, 919x973
>Ability 1: Deals 500 damage with a increased critical chance
>Ability 2: Deals 1500 damage over 30 seconds
>Most enemies have ~1000 health
File: reaction.jpg (85 KB, 1920x1080) Image search: [iqdb] [SauceNao] [Google]
85 KB, 1920x1080
>windows cursor now overlaid over everything in addition to game cursor
>dance of the cursors
>uninstall skyrim
>New games from big budget company
>Can't keep up stability with games from 1999
>Re-open the game
>The screen is cropped so you can't see half of the game
>The windows mouse and in game mouse are both visible
File: 9QUV88B.jpg (10 KB, 255x200) Image search: [iqdb] [SauceNao] [Google]
10 KB, 255x200
>Key items take up already limited inventory space
>Game gives you very different dialogue options
>They only affect the initial NPC response and literally nothing else
>start game lvl 1
>walk through ominous door behind lvl one
>final boss battle
>lose instantly
File: 1449437926190.gif (51 KB, 520x390) Image search: [iqdb] [SauceNao] [Google]
51 KB, 520x390
>Motion blur
It kills both my framerate and immersion.
Good thing most games on PC let you turn it off. But on console it just pisses me off and there is nothing i can do about it.

>shows pretty much every boss fight
>even final boss
>hit x population on a city building game
>basically forced to use unlocked building

>loading screen sticks at 99%
>loading screen is actually just a static picture with no moving segments
>literally no way to tell wether the game froze, or it's still loading
File: 1450039753404.png (140 KB, 660x135) Image search: [iqdb] [SauceNao] [Google]
140 KB, 660x135
>game has 3 final bosses for three different ending
>only one of those three bosses can actually cause the player to lose

I hate shitty bosses.
>insane amount of of obscure random options
>either google each one or just fuck with them
>you change them and keep checking the game to see if theres any difference
>no noticeable FPS drop or any visual change
>not even sure if this shits even working
File: 1445916823893.png (345 KB, 498x568) Image search: [iqdb] [SauceNao] [Google]
345 KB, 498x568
>fail a quest
File: 1448206915487.png (12 KB, 405x414) Image search: [iqdb] [SauceNao] [Google]
12 KB, 405x414
>2 paths
>one of them is optional, second one progresses story and checkpoints, so you can't go back to the second path
>you never know which is which
File: 1451616488565.gif (2 MB, 231x365) Image search: [iqdb] [SauceNao] [Google]
2 MB, 231x365
>game world or level has off the beaten path or underwater areas that take a lot of effort, skills, or enemies to fight through to reach
>get to them and explore
>literally no loot or secrets or easter eggs there

Fuck off
>key items are heavy as shit
File: 1390311950707.jpg (16 KB, 499x306) Image search: [iqdb] [SauceNao] [Google]
16 KB, 499x306
>the intro is literally in-game cutscenes set to the main theme
>next portion of a mission/quest is far away
>you just talk to someone then go back to where you were at the start

Fuck Novigrad
This is going to sound weird, but genuine difficult.
I like artificial difficulty that I can cheese past.
>>Somehow the rest of the world isn't fucked by the giant onslaught of stronger monsters on the roads
But, Anon, the game specifically shows you people talking about the difficulties they faced due to that. In fact I'm pretty sure members of the Ravens talked about getting beat by monsters on the road.
>horror game
>long, dimly lit corridor that you have to walk through

>platforming game
>drawbridge over a hazard (lava/water etc), with clearly segmented steps

>shooter game
>armored care comes to pick you up (guess who gets to man the machinegun on top)
File: 1401403411601.png (453 KB, 525x632) Image search: [iqdb] [SauceNao] [Google]
453 KB, 525x632
>Launch game
>It doesn't take focus
>Confines mouse to window behind what is focused
>Even if it does take focus, fuck whoever thinks it's okay to lock my mouse to the confines of a WINDOW unless I alt+tab
File: 888.jpg (40 KB, 500x534) Image search: [iqdb] [SauceNao] [Google]
40 KB, 500x534
>options menu has a performance indicator
>flies all over the place whenever you change options
>finally get it to maximum predicted FPS
>runs like shit
>put everything to max
>buttery smooth 120FPS.
File: 1450736421687.jpg (39 KB, 283x269) Image search: [iqdb] [SauceNao] [Google]
39 KB, 283x269
>game has collectibles
>there's either no reward or it's some cosmetic nonsense
My life on this planet is limited enough for me to ignore such bullshit
File: 1445717687790.gif (923 KB, 424x240) Image search: [iqdb] [SauceNao] [Google]
923 KB, 424x240
>clear out area of enemies
>walk 15 feet away
>turn around
>area is totally repopulated with enemies
File: 1428719710763.png (291 KB, 500x381) Image search: [iqdb] [SauceNao] [Google]
291 KB, 500x381
>Boss drops loot
>loot appears in cutscene since its rendered in engine
>loading screen
>all the loot is gone but you're still in the exact same place
>Play shitty indie 300x240 pixel game
>It doesn't crash
Witcher 1 is such a slog
File: 1430685592864.png (244 KB, 410x509) Image search: [iqdb] [SauceNao] [Google]
244 KB, 410x509
It actually annoys me when you can change the difficulty of the game mid-game with no drawback of any sort.

I know I don't have to use it, but it just being an option at all bugs me for some reason.
I mean, if you play it for the first time, you won't remember any of that shit after 5 minutes. Watching it now, they really show everything in that intro.
People are suffering, but they aren't outright fucked.
File: 1451295363287.png (57 KB, 548x546) Image search: [iqdb] [SauceNao] [Google]
57 KB, 548x546
>carrier proceeds to fly in figure eights
File: 1435532792699.jpg (59 KB, 453x439) Image search: [iqdb] [SauceNao] [Google]
59 KB, 453x439
>change video settings
>screen goes blank or full white
>wait for the settings to revert
>they never do

>I know I don't have to use it, but it just being an option at all bugs me for some reason.

This statement needs to be a banner on /v/.
File: YYOUU.png (887 KB, 595x885) Image search: [iqdb] [SauceNao] [Google]
887 KB, 595x885
>enemies drop tons of shit every time you win a fight
>no drop sorting
>inventory limit

I was referring to TW3 which I find an even bigger slog once you get to Novigrad. I was relieved any time I got sent outside the city but most of it was literally having a conversation before coming back to the city.
>Shitty tutorials
Why the fuck is this allowed?
>get to a boss/tough area
>die but keep getting better and learning the boss moves/patterns
>game keeps asking you if you want to lower the difficulty

Bonus points if it's all smug or passive aggressive.
>Final boss drops loot, but the game ends as soon as he dies. so you can never pick up the loot
>Playing through game a second time
>Still have to do the tutorial.
File: FUCKING WHY.jpg (36 KB, 210x210) Image search: [iqdb] [SauceNao] [Google]
36 KB, 210x210
>level scaling
I feel like it cheapens the experience just knowing there are people out there who lowered the difficulty before a difficult boss.

At the very least, the game should reward you for playing on a higher difficulty. Tales games do this. Games like the Witcher 3 don't.
>tutorials don't go away in new game+
File: annoying devil.webm (715 KB, 600x338) Image search: [iqdb] [SauceNao] [Google]
annoying devil.webm
715 KB, 600x338

>no tutorial
>instead you get button prompts and tips for the rest of the fucking game

I've played for fucking 30 hours, I know when to fucking crouch and which button it is.

Arbitrary fetch quests before plot advancement make my blood boil.

I got to the Driftwood Shore part in Mario & Luigi Dream Team and nearly gave up after finding out I had to find all 3 dream eggs scattered around the beach and then complete the 3 separate dream sections they unlock just to hide Peach somewhere away from Bowser. FUCK YOU
File: anime74.png (838 KB, 929x742) Image search: [iqdb] [SauceNao] [Google]
838 KB, 929x742
>Enemies don't drop everything they have

If I see a dude with a sword that wrecks me I want to be able to pick it up and wreck the next enemy I face.
I didn't fight you just to pick up your two goldpieces and leftover loaf of bread
File: 1450986102854.png (507 KB, 624x633) Image search: [iqdb] [SauceNao] [Google]
507 KB, 624x633
Oh shit you're right. I got Vizima and Novigrad confused. It's way worse in Witcher 1
>game where ammo is scarce
>your dude uses 5 bullets
>cutscene ends
>they're not actually gone from your inventory
>Hard mode/Easy mode locked to specific game versions.
>Have to complete a Normal mode run on either version to unlock the specific difficulty for that version.
>To unlock the difficulty obtained on the other version, you need to trade the 'key' with another person who's beaten the game themselves.

Holy shit Gamefreak. You introduced a difficulty setting for Pokemon Black/White 2 and made it the most roundabout fuckery just to use it.
File: joey25.png (185 KB, 314x375) Image search: [iqdb] [SauceNao] [Google]
185 KB, 314x375
>status effects don't work on anything but trash mooks who die in two hits anyway
>You have to look up on Youtube in order to understand how to even play the game.
Fuck you Paradox!
>game has unlockable costumes
>they all have horrendous clipping
>Bullets from your inventory are actually used during the cutscene
>Outcome differs if you have too few bullets

I'd play that
File: BONESAW.jpg (46 KB, 607x530) Image search: [iqdb] [SauceNao] [Google]
46 KB, 607x530
>you have to kill chain to charge up your special attack
>game spawns two or three enemies at a time
File: 1445124554300.jpg (21 KB, 640x619) Image search: [iqdb] [SauceNao] [Google]
21 KB, 640x619
>Have to replay the tutorial for the true end
File: 1434322940833.jpg (49 KB, 426x381) Image search: [iqdb] [SauceNao] [Google]
49 KB, 426x381
>Best piece of equipment in the game is dropped by the hardest, final optional boss in the game
File: anime68.png (281 KB, 909x738) Image search: [iqdb] [SauceNao] [Google]
281 KB, 909x738
Don't remind me that's the way things are anon
>4 parts of 5 of an armor set are given in the main quests
>last part of the armor set is a reward in an annoying sidequest
Everquest was great about this I loved it. You always know if the rare spawn had it's rare weapon or not.
>+1% resistance to bleeding
>Super strong attack / weapon: Only works against Djinni
>You never face Djinni in a relevant fight, ever.
>game continually thinks I'm holding the down button if I have a controller plugged in
File: joey7.png (546 KB, 2000x2284) Image search: [iqdb] [SauceNao] [Google]
546 KB, 2000x2284
what is dark corners of the earth
>Game has status ailments
>Game has armor that prevents getting status ailments
>Final Boss has an ability that negates the prevention

What's the point of even wearing it, then?
File: 1449725277591.gif (516 KB, 500x281) Image search: [iqdb] [SauceNao] [Google]
516 KB, 500x281
Witcher 3's randomized drop system for recipes and components. Finally found a golem and it didnt drop a golem heart? Oh well, too bad, better luck next time 5 hours from now when you finally come across another one.
And having tons of useless junk items you won't know if you need or not in a game with limited inventory space. The game says bear pelts are junk, but I needed one for an armor recipe, so now I have to hold on to everything.
Blade oil system could be less of a hassle too.
And when you're buying components the game doesn't tell you if you even already own it at all or not, nevermind how many like it should.
>complete quest
>item doesnt go away
I'm talking about you, New Vegas
My fucking Misc inventory is filled with DLC junk
>all status ailments have the same accuracy rate
>dungeon has teleporters
>dungeon exit is locked and the key/switch needs to be found first
>dungeon layout changes or is randomised on each entry
File: image017.jpg (116 KB, 561x639) Image search: [iqdb] [SauceNao] [Google]
116 KB, 561x639
>Loot that enemies drop can get stuck behind invisible walls or over bottomless pits
>the dodge is shit
>so shit you better never use it and simply try to avoid attacks by strafing/sprinting away
File: great white.webm (2 MB, 1280x720) Image search: [iqdb] [SauceNao] [Google]
great white.webm
2 MB, 1280x720

>get highly leveled weapon
>it's a toxic/poisonous weapon
>base damage is shit
>b..but it's toxic/poisonous
>-1hp drained per second
>most enemies have hp in the hundreds or thousands
>New Vegas
What the fuck is food additive and why is it in my inventory?
File: 1419158639430.gif (149 KB, 241x182) Image search: [iqdb] [SauceNao] [Google]
149 KB, 241x182
>Fucking rare drops period
File: The derailer perk.gif (165 KB, 620x446) Image search: [iqdb] [SauceNao] [Google]
The derailer perk.gif
165 KB, 620x446
>You only get to use the most fun weapon in the game for 1 level.
Games that wanted to be marketed as "Games for Windows" were actually prohibited from doing this. There had to be a moving element on the screen at all times.
Hidden Machines in Pokemon are pretty high up for me, only being equal with games that make ailments pointless to use.

>item 3% drop rate
>after 100 drops still never get the item

>the game has a blue magic system
>one of the bosses in the game has a move that can be learned only in that boss fight
>it's a 1% chance to learn upon being hit
>watching perfectly heterosexual porn
>mum walks in and I panic alt+tab
>very homosexual porn

its not my fault mum
>Unique drops can be lost forever

I'd rather have my guaranteed post patch titanite lizard drops than the bullshit of them falling into a pit and seeing the goodies in the abyss.
File: eb7.jpg (123 KB, 942x943) Image search: [iqdb] [SauceNao] [Google]
123 KB, 942x943
>Best friend who genuinely looks like they'll never betray you
>Turns out to serve the final boss, or is the final boss.
Sjw influence
those dudes look fucked
>Silent Hill: Homecoming
Impossible to fucking alt-tab and get back into it without it crashing, I didn't expect much but fuck
>And when you're buying components the game doesn't tell you if you even already own it at all or not, nevermind how many like it should.

Bloody hell, this. It's a fundamental part of any game that handles item resources.
vanilla Wow did it

like if you were a mage your spells would all get resisted for no real reason doing no damage
>enemy drops loot on floor
>go over to pick it up
>it falls through the floor
Fucking DaSII
>Drop rate for item you want is high
>Grinding enemies for that item drop
>Literally drops 10 rare items with 10% > drop rates
>Drops everything that enemy can drop but what you want
I'm looking at you Alonne Knights and you dumb ass Black Steel Katana
>game is already balls hard
>slog through getting all items and secrets
>"Hard mode unlocked!"
pic related
>Item has 50% drop chance
>Takes 10 fucking kills to get it
>boss has week long lockout

Fuck you Majordomo

Evolve does this.
>Slavs in MP games
i thought i was the only one reeeeeeee
>the difficulty in the game comes from constantly recycled gimmicks and not actual level design
>eventually get through Hard
>"Nightmare mode unlocked!"
File: 2.jpg (3 KB, 126x126) Image search: [iqdb] [SauceNao] [Google]
3 KB, 126x126
This. It's like DBZ, if your power level level is like, 800, and your opponent is 1000, you can't beat him no matter how skilled you are or if you specialized in certain skills. It's pretty fucking annoying.
>tfw i made an OC of this and the cave explorer comic that got reposted a lot, but lost it three computers ago
>spend two hours getting your shit pushed in and finally beat the level
>character dies in the cutscene
File: 1397166191296.jpg (51 KB, 394x379) Image search: [iqdb] [SauceNao] [Google]
51 KB, 394x379
Dead space did this and I hate it
>have to restart from scratch on the highest difficulty
fuck you
File: 1442776727404.png (538 KB, 604x536) Image search: [iqdb] [SauceNao] [Google]
538 KB, 604x536
>Drop gun
>Falls through the floor
File: 1389719792020.png (109 KB, 576x507) Image search: [iqdb] [SauceNao] [Google]
109 KB, 576x507
>Game is being bullshit cheap
>Maybe you'd like to change to easy mode? :^))
>Game is a 100 hour long RPG
>You have to beat the game to unlock hard mode
File: sandwich time.png (519 KB, 699x417) Image search: [iqdb] [SauceNao] [Google]
sandwich time.png
519 KB, 699x417
>accidentally sell an item I wanted
>get 300 gold for it
>costs 15,000 gold to buy it back
fucking crysis
>harder difficulty just turns the enemies into bullet sponges
File: loading-bar.gif (134 KB, 450x150) Image search: [iqdb] [SauceNao] [Google]
134 KB, 450x150
>Loading bar loops
>Chestplate of Defending: 500 gold
>Hardened Chestplate of Defending: 50,000 gold
>get the squirter gun in MGS5
>never use it because obvious joke weapon
>hours later realize it can be used on Fire Man
>take that shit all the way up to the mountain
>because its equipped you have no other pistol
>finally get to him
>squirt him
even worse is that it actually DOES work if you use 20+ times, but you will be berated by your comms team the whole
File: anime425.png (291 KB, 577x428) Image search: [iqdb] [SauceNao] [Google]
291 KB, 577x428
Prices in RPGs are fucked beyond belief

>Scroll of inflict papercut - 12000 gold

Literally fucking why?

>go through level
>have to turn around and go back through level
>oh, and all the enemies respawned

File: 1387244754455.jpg (25 KB, 600x450) Image search: [iqdb] [SauceNao] [Google]
25 KB, 600x450

>shark attacking a boat

Wow fuck that
File: im out.jpg (14 KB, 345x365) Image search: [iqdb] [SauceNao] [Google]
im out.jpg
14 KB, 345x365
>MC is a whiny bitch
>MC has a bad moveset
>MC is the only physical fighter you'll have for 10+ hours and mages suck ass early game
>You're forced to play as the MC multiple times for story related reasons
>game is balls hard
>not because of the platforming, but because of its boner for flappy bird
Holding up people and disabling comms equipment is fun with the squirtgun though.
>The difficulty key is removed if you restart the game
File: 1443502661200.jpg (273 KB, 576x576) Image search: [iqdb] [SauceNao] [Google]
273 KB, 576x576
>2 added it

Made Zealot a piece of piss, though I did do a real run later.
File: 1399769186420.jpg (259 KB, 850x850) Image search: [iqdb] [SauceNao] [Google]
259 KB, 850x850
Shark-kun is cute!
File: 4233252342.jpg (6 KB, 175x212) Image search: [iqdb] [SauceNao] [Google]
6 KB, 175x212
>Get the best weapons in a level with plenty of ammo left over.
>Character you play as drops it for shitty default weapons next level
File: 1.jpg (18 KB, 240x312) Image search: [iqdb] [SauceNao] [Google]
18 KB, 240x312
You can also use it to destroy generators with the water
Mountain Blade
>tfw grinding for ages to get +1 on your armour
>go back to blacksmtih and he's not selling it anymore.
File: 1445798260633.png (98 KB, 233x203) Image search: [iqdb] [SauceNao] [Google]
98 KB, 233x203
>Game lets you sell weapons that you have equipped without letting you know you have them equipped
>Can't see what a weapon's stats are like until you buy it.
>mc goes down in the fight it's game over.
>even though you have revival items.
File: 38234597_p0.png (693 KB, 1050x1050) Image search: [iqdb] [SauceNao] [Google]
693 KB, 1050x1050
That fucking squirt gun
>Sets off mines
>Stuns enemy
>Can be used to distract
>Completely silent
File: 1438232517753.jpg (41 KB, 480x712) Image search: [iqdb] [SauceNao] [Google]
41 KB, 480x712
>Run out of money and need items
>Go back to make some more
>Find out nothing in the game respawns
Maya? or her Magatama?
Maya. She's hot and has ugly feet
File: 1428105932397.jpg (24 KB, 224x262) Image search: [iqdb] [SauceNao] [Google]
24 KB, 224x262
>Artificial difficulty i.e. grinding that takes more than a few days. I'm talking more about for items than I am for levels, though leveling shouldn't be tied to a (heavy)grind either really, where's the fun in that?
>pay to win
>invisible walls
>unskippable end credits
>unskippable end credits with no special cinematic played at the end for making you sit through the end credits.
>unbalanced class systems
>shoehorning Looking at you Skyrim, fuck your mages guild and thieves guild, do my biceps look like they care about your honor and arcane arts?
>game promises interesting dialogue choices, then proceeds to be yes, no , sarcastic yes, and i dun wanna answer just yet gibbe a sec.
>PowerPoint slideshow tutorials
>tutorials AFTER you were required to do something new
>intro cutscene that has absolutely nothing to do with the rest of the game

What the fuck, Compile Heart?
>can read a description of your abilities but you arent given any numbers
>tons of them have similar descriptions such as "deals damage to one enemy", "increases X stat", etc but with different values
>you cant tell what is good and what is bad because of this
>teleporter maze
yeah. its really useful once you get the hang of it, but i'm still salty since being rewarded for creative item use is a staple of MGS except this one time. makes no sense
File: 1361801273447s.jpg (3 KB, 125x125) Image search: [iqdb] [SauceNao] [Google]
3 KB, 125x125
my job
kids dont get a job in the industry, it sucks and destroys everything you love. Or fuck it do code so at least you can escape
>>unskippable cutscenes
If you're going to replay the game, you should replay the full game, faggot.
File: burger.png (38 KB, 135x161) Image search: [iqdb] [SauceNao] [Google]
38 KB, 135x161
>Menacing looking party member who has a grudge against the main character
>Never betrays you
>early game and first 2 playthroughs are balanced and fun
>3rd playthrough and above is grindy bullshit where enemies take a gorillion hits and the lowest schlub can OHK you
guess the series
it's not the souls series
File: qkfuOMz.gif (2 MB, 500x338) Image search: [iqdb] [SauceNao] [Google]
2 MB, 500x338
>one weapon in pvp is blatantly better than everything else
>It only drops off one enemy who doesn't respawn and rarely drops it
Fuck you Dark Souls 2.
File: 1449688297745.gif (2 MB, 316x213) Image search: [iqdb] [SauceNao] [Google]
2 MB, 316x213
>alt-tab back into the game
>black screen
>game works again
>Can't see what a weapon's stats are like until you buy it.

They actually did that in Diablo 2. You could "gamble", by purchasing a weapon with unknown stats. If it happened to be really good you could sell it back for more than you gave. It ended up just being abusable though, if you bought certain weapons like wands they would always be worth more, so you could get free money that way.
File: 1417209164685.png (437 KB, 388x545) Image search: [iqdb] [SauceNao] [Google]
437 KB, 388x545
>Pants of +5 damage resist 50g
>Pants of +6 damage resist 50000g
>Bosses can get super armor/get immunity to stuns and ailments at random during a fight
+43 armor
+44 armor

Cheat Engine is a must for DaS2 PvP as long as you don't use it to grief
>Political agenda

>Tutorial level

>Only options for anti aliasing is FXAA


>Puzzles which can't be solved by reason but by trying randomly for a long time
>tutorials are all longass walls of text
>no interactivity
>Not even any narration

Paradox, I love your games but you sure do suck at making them easy to play.
File: 1443972728254.jpg (1 MB, 1436x1080) Image search: [iqdb] [SauceNao] [Google]
1 MB, 1436x1080
>Only get money from quests
>Can only purchase ammo
>Long shitty shooter section coming up
File: angry bowtie.jpg (25 KB, 500x500) Image search: [iqdb] [SauceNao] [Google]
angry bowtie.jpg
25 KB, 500x500
>1,5% chance on hit for neglible effect for a duration where the enemy has died 4 times over
>can't compare weapon stats unless both weapons are equipped
>item descriptions have very detailed descriptions with numbers down to 2 decimal places
>These numbers they adjust aren't visible anywhere in the game
Generally I agree, but Way of the Samurai is the worst about this. The game is based on branching stories and replayability. but it has several cutscenes that replay no matter which storyline you're following and they fucking last for way too long and are unskippable.

Honestly the only thing that keeps the game from being a legit 10/10
>Best friend who genuinely looks like they'll never betray you
>liking tropey shit
Seriously, what the fuck is wrong with you?
File: 1393117188088.jpg (18 KB, 324x270) Image search: [iqdb] [SauceNao] [Google]
18 KB, 324x270
>use squirtgun on coms
>nobody suspects a thing
>use squirtgun on generator
File: TrollSkullSK.png (43 KB, 350x466) Image search: [iqdb] [SauceNao] [Google]
43 KB, 350x466
>Useless items with no purpose at all
>pre-order dlc
>season pass
>cosmetic dlc
>early access
File: 1452266471838.gif (2 MB, 350x197) Image search: [iqdb] [SauceNao] [Google]
2 MB, 350x197
>unlock new costume
>it's a palette swap
Valve games man.
Generators usually don't go offline for no reason, dingus.
Fuck whoever decided the drops in DaS2.
>Hey, lets make shit drop from enemies that don't show up unless you meet a specific requirement, have nonexistent drop rates for said items, and don't respawn
Cheat engine is a requirement for that game.
One of the few things EO4 did right.
Other than being the best EO.
Lordly ugly armour because I'm a top-tier sperg.

That 1 extra armour is going to be a great deal of help when I'm cleaving skulls at the top of a ladder unless my retard troops push me off again.
>Game has invisible walls
>Enemies can walk through the walls and be out of attack range.
neither, i was roleplaying as robin hood, i picked the leather jerkin.
File: 1451963253729.jpg (32 KB, 410x396) Image search: [iqdb] [SauceNao] [Google]
32 KB, 410x396
>get well over 100 fps during massive battles with many enemies on screen
>look at some random wall or section of the map
>fps drops to single digits

Not really mad, just perplexed.
Makes sense. They only use the coms when they're on alert. They're always using the generator to power something
File: chen sweat.jpg (80 KB, 720x800) Image search: [iqdb] [SauceNao] [Google]
chen sweat.jpg
80 KB, 720x800
>everything costs way too much early game
>by mid game you have so much money you can buy everything in the game multiple times over
>subtitles off by default and can't be turned on until you get past the unskippable intro cutscene
>no option to skip tutorial
>lowest FOV by default
>multiple actions are binded to the same key
DLC announced before the game is even released.

Makes me think the game is an incomplete piece of shit.
File: 1409954771497.jpg (432 KB, 1150x1600) Image search: [iqdb] [SauceNao] [Google]
432 KB, 1150x1600
>Hey player, did you know you can do a rolling fart attack?
>It takes 30 seconds to charge up, has zero range, leaves you vulnerable for 5 seconds, and does 5hp damage, but it's funny right?
>In order to progress, defeat 5 enemies using only the Rolling Fart attack
Can't I stick to killing things with my sword of galactic might? It's worked so far.
>power of friendship
>tiny labyrinths
>every enemy is a joke because the game is on permanent easy difficulty
Fashion, always fashion.

DaS2 does that. Frustrating.
ANOTHER settlement needs our help
File: 1358206611238.png (12 KB, 410x528) Image search: [iqdb] [SauceNao] [Google]
12 KB, 410x528
>There's a sprint button, but you can sprint forever

Yeah, no shit
You expect a base of soldiers to don't care about all the lights suddenly going off?
>Oh right when did we last refuel it?

At least fucking go see if it just needs some maintenence after having stood in the desert for a few months instead of suspecting enemies.
Trying to wrap my head around which weapon you guys are talking about, but most weapons I see in PvP are Santier's spear and shit with broken ghost range to them. Mainly two handers.
File: 1419544876994.gif (1 MB, 223x200) Image search: [iqdb] [SauceNao] [Google]
1 MB, 223x200
>only way to progress in game is to go through small doorway
>throw grenade/molotov at the other side of doorway
>after explosion/fire ends you go through doorway
>enemy was hiding on behind the doorway and ambushes you anyway
File: satan pooh.gif (982 KB, 320x287) Image search: [iqdb] [SauceNao] [Google]
satan pooh.gif
982 KB, 320x287
>sell starting weapon cause it's worth more than bronze sword+1
>find out later on a gaming forum that you could've upgraded that weapon to the strongest weapon in the fucking game, the weapons you get in the post game dungeon don't even come close to it
>its impossible to get it back
MoHun 4 had this. Sucked when whale dragon died behind it. Couldn't carve shit...
>Fight a tough enemy
>He drops some rare item
>Cutscene happens
>Over your character's shoulder you can see the item start to shimmer and disappear while he keeps talking
File: 270.jpg (18 KB, 296x203) Image search: [iqdb] [SauceNao] [Google]
18 KB, 296x203
>stupid, pointless side minigame-tier bullshit that isn't even necessary and is obviously thrown in to bloat gameplay time
>the sequel does the same thing
File: 1426187510983.jpg (6 KB, 201x201) Image search: [iqdb] [SauceNao] [Google]
6 KB, 201x201
I love Warband, 500hrs and counting but fuck me it doesn't run well on nvidia cards. Big fps drops is medium battles.
File: neat.jpg (28 KB, 500x491) Image search: [iqdb] [SauceNao] [Google]
28 KB, 500x491
File: 1435294050352.png (146 KB, 284x352) Image search: [iqdb] [SauceNao] [Google]
146 KB, 284x352
>Sprint button requires you to keep holding it down
>Sprint button is your joystick

Even when it's on a keyboard it's complete ass.
File: 1400162103999.gif (2 MB, 260x242) Image search: [iqdb] [SauceNao] [Google]
2 MB, 260x242
>Sprinting makes you control like a buttered snake
>Jogging makes you move too slowly
>Walking? What's the matter with you?
File: 1359667385798.gif (2 MB, 350x283) Image search: [iqdb] [SauceNao] [Google]
2 MB, 350x283
>game has no respawning enemies
>you can legitimately clear out areas and be safe
>come up to one section
>need to perform action that can be interrupted by attacking enemies
>try to clear out enemies
>more come
>kill them
>more come
>burn through all my ammo and gear

Fucking Dead Space 2
File: 1450483536452.gif (2 MB, 400x400) Image search: [iqdb] [SauceNao] [Google]
2 MB, 400x400

>If you stand/crouch/walk without getting hit, you heal
>slow mo bullshit when you get low hp
>bosses/mobs that take a very long time to kill, but have little tactic/effort to defeat them.

pretty generic complaints I guess
>everything is really cheap
>except for that one item that's actually an upgrade, it costs 7 trillion coins.
File: 1427650679944.jpg (82 KB, 555x526) Image search: [iqdb] [SauceNao] [Google]
82 KB, 555x526
What the fuck else did you expect at the end of the fucking game
File: 1377479053712.gif (781 KB, 320x287) Image search: [iqdb] [SauceNao] [Google]
781 KB, 320x287
Probably some bullshit LOD code. If you are closer to something, your GPU might be good at rendering it.
what card? I get zero drops on my memecard 970 and i never got drops on my old 660ti
File: 1450408930782.jpg (61 KB, 540x960) Image search: [iqdb] [SauceNao] [Google]
61 KB, 540x960
>Have to infiltrate base full of weak enemies
>Being detected is game over
How about I just kill every living creature that opposes me? Huh? It's worked so far.
The Peach/TEC segments in TTYD were great, fuck you.
File: Fuck.png (122 KB, 540x353) Image search: [iqdb] [SauceNao] [Google]
122 KB, 540x353
>Beating highest difficulty gives you rewards
>Doesn't give the rewards you can get from lower difficulties
>Game has a crafting mechanic
>Ingredients are some weapons that stopped being useful ages ago or that can't be re obtained
The monastery scimitar only drops in new game plus, only drops from one black phantom who doesn't respawn and has a low drop chance. If you want it legit you'll be burning bonfire ascetics and fighting the guardian dragon for hours.
Before it was patched it was blatantly better at parrying than anything else in the game.
File: iHateYou.gif (2 MB, 448x252) Image search: [iqdb] [SauceNao] [Google]
2 MB, 448x252
Well there goes the thread.
Not the potion mixing part, you shit-licking faggot.
I was using a 560ti until recently but it would still get big drops from 60 to maybe 15fps.
Upgraded to a R9 380 so hopefully I can finally use the battle sizer mod
>crucial in game function stops working
Thanks Square Enix
Mount & Blade freaked me the fuck out with this.
>you start the game with a heirloom sword or a sword from an elite group, or just "[your name]s Sword"
>Hold on to it for the entirety of the game for no reason, other than keeping NPCs from owning the sword.
>Start game with iron sword and leather armor
>First shop only sells iron swords and leather armors
>game has controller support
>start up game
>start up controller
>doesn't work
>restart game with controller still on
>it werks
I personally never liked the battle sizer mod
i mean how am i supposed to beat 1500 troops if they all spawn at once?
I still wish there was a mod to increase the troop count without making it spawn LITERALLY EVERYONE
File: explosion-proof.jpg (95 KB, 879x660) Image search: [iqdb] [SauceNao] [Google]
95 KB, 879x660
>you're caught in a cutscene immediately after
Oh yeah, that weapon, I remember seeing it when I was looking up weapons trying to see what I would be interested in playing with. I just remember its look, didn't recall how to get it, is it really that good? Even after the patch?
did they died
>alt+tab back in
>connection lost
File: cyber-woman-corn.jpg (107 KB, 955x1300) Image search: [iqdb] [SauceNao] [Google]
107 KB, 955x1300
File: PinkPuff-ffiv.gif (21 KB, 800x800) Image search: [iqdb] [SauceNao] [Google]
21 KB, 800x800
>attack and interact mapped to the same button
>you're caught by only 3 dudes
>you could have easily fucking killed/stunned them
thanks MGS
What I want most is a game that combines mountain blade with total war.

HUGEASS BATTLES, big strategy and shit. You can still personally carve up niggas.
An enemy that completely fucks your day up, has a ton of health, and is super mobile, or hides.
See: Illusionists in Helldivers, or Ace pilots in Luftrausers.
Fucking bullshit
>it's a group of generic enemies you could kill in seconds
Fuck anything with stealth.
>turn based battles
Fuck you, I like turn based.

The rest of your points are valid, though.
Dynasty Warriors Empires :c)
>Mow the grass
>Not the cow
>alt-tab back into game
>game is now in windowed mode
>Boss starts his battle by shooting you during his cutscene
>Literal unavoidable damage
Guess the game
I think some mods let you spawn it in waves, so 1000 troops over 20 waves etc

I was using it for ACOK as a lowly foot soldier in battles with loads of lords at each other. Prepare for fisting sunshine.
File: 1424809424814.jpg (12 KB, 300x168) Image search: [iqdb] [SauceNao] [Google]
12 KB, 300x168
>chest at the end of a long winding path with shittons of enemies
>reach the end, open it
>You found 10 gold
>game is either dark or foggy
>enemies are far out of your sight range
>they can still hit you with pinpoint accuracy
File: 4XiFgJp.webm (615 KB, 404x720) Image search: [iqdb] [SauceNao] [Google]
615 KB, 404x720
>no option to to rebind keys

And that's the only time I will ever get tricked into buying an early access game.
I really wish TWEAKMB worked with every single mod
seriously, I just want to roll around with a beefhuge army without them getting butthurt at literally everything
>you get better/more loot during your quest than what you're rewarded with
File: 1447558934242.jpg (251 KB, 1920x1080) Image search: [iqdb] [SauceNao] [Google]
251 KB, 1920x1080
Was that a real score in Clapball?
File: buyers remorse.png (74 KB, 713x240) Image search: [iqdb] [SauceNao] [Google]
buyers remorse.png
74 KB, 713x240
>someone else had already looted in and left only the trash items
File: 1438376423003.png (305 KB, 413x293) Image search: [iqdb] [SauceNao] [Google]
305 KB, 413x293
>Esc Key quits the game with no confirmation and no survivors
>Game has no Quicksave
>turn based battles
Nomura pls go
Banjo Tooie did something like that, although I think it was the Mumbo Imposter zapping you with his staff instead.
Still started the fight with one less piece of health.
>scripted boss fight
>scripted final boss
File: 1317965306066.png (121 KB, 500x500) Image search: [iqdb] [SauceNao] [Google]
121 KB, 500x500
>QTEs during cutscenes
probably already been written a billion times but

>fucking brutally kick the bosses ass during gameplay
>you're the one being destroyed in next cutscene

Yes, it was in 2014 when Tampa didn't have a good QB and just got a new coach with a new defensive scheme.
File: 1442623087819.jpg (24 KB, 317x284) Image search: [iqdb] [SauceNao] [Google]
24 KB, 317x284
>Turn based game, battles are slow as shit
>It has a time limit segment
>doesn't seem that bad, after all they wouldn't have the timer running during the battle righ-
File: Depression.jpg (85 KB, 500x402) Image search: [iqdb] [SauceNao] [Google]
85 KB, 500x402
>Hear the coming dungeon is filled with poison
>Anti poison is expensive but think it's worth it to spend the dosh
>Anti poison potions are scattered all over the dungeon
>See new enemy that is huge in comparison to everything earlier
>Killing it doesnt actually give anything special
>Hard as balls miniboss only function is to lower your health for the coming battles
>Get nothing out of beating it
>final boss fight is QTE despite there never being any other QTE fights prior in the game
Super robot taisen OE does this and that shit is BALLS, you'd think in a game with over 100 units you could use who you wanted but NOPE. what that the zoids missions stop using Van in chapter 4, thats cool we'll wait til you get to chapter 8 and make you solo a mission with him hope you kept him leveled up.
Fuck that game.