[Boards: 3 / a / aco / adv / an / asp / b / bant / biz / c / can / cgl / ck / cm / co / cock / d / diy / e / fa / fap / fit / fitlit / g / gd / gif / h / hc / his / hm / hr / i / ic / int / jp / k / lgbt / lit / m / mlp / mlpol / mo / mtv / mu / n / news / o / out / outsoc / p / po / pol / qa / qst / r / r9k / s / s4s / sci / soc / sp / spa / t / tg / toy / trash / trv / tv / u / v / vg / vint / vip / vp / vr / w / wg / wsg / wsr / x / y ] [Search | Extra juicy! | Home]

Solving linux problems thread

This is a blue board which means that it's for everybody (Safe For Work content only). If you see any adult content, please report it.

Thread replies: 25
Thread images: 4

Hey guys I checked the catalog and didn't see a friendly linux thread so here it is. And I have an issue I need help with! I'll help with as many as I can if someone can help with this
>want to get into linux
>install Debian Jesse, via USB, because it's not 2006
>try to install lynx
>tells me I have to insert installation cd
>Okay, well, I guess I'll insert installation USB instead and see what happens
>GRRRRR, FEED ME THE INSTALLATION CD THAT I WASN'T INSTALLED FROM
What config file am I gonna have to edit to fix this? And how? Pic related
>>
>>51516897

You should have installed Mint like we told you earlier OP.
>>
>>51516897
You might've disconnected the USB drive, try installing it again
>>
You should be able to simply google the problem dude. Debian includes a line in their config for package sources to use the cd.
>>
>>51516897
take a screenshot of "cat /etc/apt/sources.list".

You might not have disabled the cd-rom sources.
>>
>>51517050
I had to switch to my phone so I can't screencap anything tonight but that's likely the problem since I've never touched anything under /etc, so I just open /etc/apt/sources.list, comment the cd-rom source(s) and uncomment the usb source?
>>
>>51517112
Comment the cd-rom sources AND the usb source.

Once you have your system installed, you generally want to update ONLY through the internet, as that's where the latest software and security updates will be available.

Debian has always done this for me automatically, not sure if they changed something.
>>
The best way to fix linux problems is to install Windows 10 ;)
>>
>>51516897

OP, this might be of use...of course your situation requires knowledge of linux basics like vi, mount, etc.

https://wiki.debian.org/SourcesList


"CD-ROM"

"If you'd rather use your CD-ROM for installing packages or updating your system automatically with APT, you can put it in your /etc/apt/sources.list. To do so, you can use the apt-cdrom program like this:

# apt-cdrom add

with the Debian CD-ROM in the drive.

You can use -d for the directory of the CD-ROM mount point or add a non-CD mount point (i.e. a USB keydrive)."


>tfw you google things for people on 4chan
>inb4 OP asks how to edit /etc/apt/sources.list
>>
>try to set up raid in mdadm
>doesn't work
>error message doesn't say jack shit
>something about md0 not set or someshit
>google returns nothing useful
>spend entire day trying to figure out whats wrong
>had to try a bunch of different shit
>finally figure solves problem
>doesn't work because drives were formatted NTFS
>format drives in EXT4
>works now
why can't linux just werk?
>>
>>51517399

Linux does "just werk".

The problem is the user/admin does not "just werk".

aka, pebkac

Q.E.D.
>>
File: have_a_seat.jpg (12KB, 450x675px) Image search: [iqdb] [SauceNao] [Google]
have_a_seat.jpg
12KB, 450x675px
>>51517314

It's starting to look like Botnet 10 will be OP's only hope of getting his computer usable again.

When you google the message about inserting the Jessie DVD, THE FIRST FUCKING SEARCH RESULT is a Debian forum post describing exactly how to fix his problem.

Instead he comes on here and has us fix his problem for him. This does not bode well for a Linux newbie.

Of course, OP is fixated on getting Debian installed for some reason...something about full disk encryption. Windows 10 phones everything home, including hashes of images on your hard drive...spooky stuff.
>>
>>51517441
if it just werk it would give an error that is informative so people could actually, you know, figure it out without hours of trial and error?
>>
>>51517441
PROBLEM EXISTS BETWEEN KEYBOARD AND CHARI

learned that in my A+ class i paid a thousand dollars for
>>
File: you got mail.jpg (21KB, 590x350px) Image search: [iqdb] [SauceNao] [Google]
you got mail.jpg
21KB, 590x350px
>>51517721
>hours of trial and error
>hours
>just doing shit randomly with no fucking clue
>what is stdout, stderr, syslog, dmesg, /var/log, man, info, google, tldp.org

Anon, in your case the solution couldn't be easier: sudo rm -rf /

There's another OS out there with your name on it!
>>
>>51517399
>wasn't using a linux filesystem
You caused your own problem.
>>
>>51516897
Why it's so slow?
>>
>>51518100

alright, now that is some badass wallpaper right there
>>
>>51517885
>>51517616
Good job rajeesh, check your bank account for that $0.25
>>
>>51517176
They haven't changed anything, it's still supposed to automatically disable installation from USB/CD media. OP fucked something up during installation, or there might be a bug in the installer. I for one didn't see this issue crop up when I did a netinstall from USB.
>>
>>51518226

Sweet, my first pro-Linux shill deposit! Time to go shit in the street in celebration.
>>
>>51516897
WAYLAND never ever.
>>
>install Mint for the first time
>looks good
>make password and everything
>reboot
>login screen
>type the password
>don't work
>reinstall make it login on boot
>password is still not the same as what I put In

My problem is that linux changed my password to something eles wtf I'm new to Linux
>>
>>51517050
just put a # before anything with cd
http ftp mirrors are good

typical debian but you only have to fix this once
>>
I need help with XFCE, every time i right click to get the context menu appear, if i dont unpress the button i can move the mouse to an option of the context menu and then unpress the mouse button and it will click that option (notice that this shouldnt be happening, continue reading for why). The problem? When in a regular use, you probably are going to press the right click, and before unpressing you are going to move the mouse just 2 or 3 pixels at least into the context menu because you have the intention of using one of those options and because inertia you are going to move it just a bit, and boilá, first option clicked without wanting to


I need to know if this happens to you, and how to disable it
In Windows for example this doesnt happens, you have to click twice, one for opening the menu and one for clicking the option (and the second one with the other mouse button)
I dont know/remember if this happens in the rest of DE
Thread posts: 25
Thread images: 4


[Boards: 3 / a / aco / adv / an / asp / b / bant / biz / c / can / cgl / ck / cm / co / cock / d / diy / e / fa / fap / fit / fitlit / g / gd / gif / h / hc / his / hm / hr / i / ic / int / jp / k / lgbt / lit / m / mlp / mlpol / mo / mtv / mu / n / news / o / out / outsoc / p / po / pol / qa / qst / r / r9k / s / s4s / sci / soc / sp / spa / t / tg / toy / trash / trv / tv / u / v / vg / vint / vip / vp / vr / w / wg / wsg / wsr / x / y] [Search | Top | Home]
Please support this website by donating Bitcoins to 16mKtbZiwW52BLkibtCr8jUg2KVUMTxVQ5
If a post contains copyrighted or illegal content, please click on that post's [Report] button and fill out a post removal request
All trademarks and copyrights on this page are owned by their respective parties. Images uploaded are the responsibility of the Poster. Comments are owned by the Poster.
This is a 4chan archive - all of the content originated from that site. This means that 4Archive shows an archive of their content. If you need information for a Poster - contact them.