[Boards: 3 / a / aco / adv / an / asp / b / biz / c / cgl / ck / cm / co / d / diy / e / fa / fit / g / gd / gif / h / hc / his / hm / hr / i / ic / int / jp / k / lgbt / lit / m / mlp / mu / n / news / o / out / p / po / pol / qa / qst / r / r9k / s / s4s / sci / soc / sp / t / tg / toy / trash / trv / tv / u / v / vg / vip /vp / vr / w / wg / wsg / wsr / x / y ] [Search | Home]
4Archive logo
Ffmpeg error
If images are not shown try to refresh the page. If you like this website, please disable any AdBlock software!

You are currently reading a thread in /wsr/ - Worksafe Requests

Thread replies: 13
Thread images: 2
This is the text of the error.
>Error while opening encoder for output stream #0:1 - maybe incorrect parameters such as bit_rate, rate, width or height

These are my specs.
>OS – Ubuntu 14.04 LTS (64 bit)
>Memory – 5.7 GiB

These are the commands I used to install ffmpeg.
>sudo add-apt-repository ppa:mc3man/trusty-media
>sudo apt-get update
>sudo apt-get install ffmpeg
>sudo apt-get install frei0r-plugins

Since installing ffmpeg, I have successfully made two webms. I made them using the following commands, and did not receive any errors.
>ffmpeg -i ./\[Anime-Koi\]\ Hitsugi\ no\ Chaika\ -\ 01\ \[h264-720p\]\[C93D7857\].mkv -ss 00:00:00.000 -to 00:01:30.000 -b:v 290K -b:a 64k -vcodec libvpx -vf scale=640:-1 -acodec libvorbis -pass 1 -sn Hitsugi_No_Chaika_OP.webm
>ffmpeg -i ./\[Anime-Koi\]\ Hitsugi\ no\ Chaika\ -\ 01\ \[h264-720p\]\[C93D7857\].mkv -ss 00:00:00.000 -to 00:01:30.000 -b:v 290K -b:a 64k -vcodec libvpx -vf scale=640:-1 -acodec libvorbis -pass 2 -sn Hitsugi_No_Chaika_OP.webm
>ffmpeg -i ./PSNR.Planetes.01.mkv -ss 00:00:00.000 -to 00:00:48.000 -b:v 618K -b:a 64k -vcodec libvpx -vf scale=640:-1 -acodec libvorbis -pass 1 -sn Planetes_E01.webm
>ffmpeg -i ./PSNR.Planetes.01.mkv -ss 00:00:00.000 -to 00:00:48.000 -b:v 618K -b:a 64k -vcodec libvpx -vf scale=640:-1 -acodec libvorbis -pass 2 -sn Planetes_E01.webm

However, when I tried to make a third webm, I started getting the error I quoted above. Here is a list of all of the commands I have attempted. Every single one has given me the exact same error.
>ffmpeg -i ./Ergo\ Proxy\ -\ 16\ NLT-Release.mkv -ss 00:01:13.000 -to 00:01:25.000 -b:v 2666K -b:a 64k -vcodec libvpx -vf scale=640:-1 -acodec libvorbis -pass 1 -sn Ergo_Proxy_E16.webm
>ffmpeg -i ./Ergo\ Proxy\ -\ 16\ NLT-Release.mkv -ss 00:01:13.000 -to 00:01:25.000 -b:v 2666K -b:a 64k -vcodec libvpx -vf scale=640:-1 -acodec libvorbis -f webm -pass 1 -sn /dev/null
>>
>ffmpeg -i ./Ergo\ Proxy\ -\ 16\ NLT-Release.mkv -ss 00:01:13.000 -to 00:01:25.000 -b:v 2666K -b:a 64k -vcodec libvpx -vf "scale=640:-1" -acodec libvorbis -f webm -pass 1 -sn /dev/null
>ffmpeg -i ./Ergo\ Proxy\ -\ 16\ NLT-Release.mkv -ss 00:01:13.000 -to 00:01:25.000 -b:v 2666K -b:a 64K -vcodec libvpx -vf scale=640:-1 -acodec libvorbis -pass 1 -sn Ergo_Proxy_E16_00-01-13.webm
>ffmpeg -i ./Ergo\ Proxy\ -\ 16\ NLT-Release.mkv -ss 00:01:13.000 -to 00:01:25.000 -b:v 2666K -b:a 64K -vcodec libvpx -vf "scale=640:-1" -acodec libvorbis -f webm -pass 1 -sn /dev/null
>ffmpeg -i ./Ergo\ Proxy\ -\ 16\ NLT-Release.mkv -ss 00:01:13.000 -to 00:01:25.000 -vf "scale=-1:360" -vcodec libvpx -acodec libvorbis -b:v 2666K -b:a 64K -f webm -pass 1 -sn /dev/null

I then attempted the following commands, on advice from someone on /wsg/.
>sudo add-apt-repository ppa:mc3man/trusty-media
>sudo apt-get update
>sudo apt-get dist-upgrade

After attempting these, I still got the error when I entered any of the following commands.
>ffmpeg -i ./Ergo\ Proxy\ -\ 16\ NLT-Release.mkv -ss 00:01:13.000 -to 00:01:25.000 -vf "scale=-1:360" -vcodec libvpx -acodec libvorbis -b:v 2666K -b:a 64K -f webm -pass 1 -sn /dev/null
>ffmpeg -i ./Ergo\ Proxy\ -\ 16\ NLT-Release.mkv -ss 00:01:13.000 -to 00:01:25.000 -vf scale=-1:360 -b:v 2666K -c:v libvpx -b:a 64K -c:a libvorbis -f webm -pass 1 -sn /dev/null
>ffmpeg -i ./Ergo\ Proxy\ -\ 16\ NLT-Release.mkv -ss 00:01:13.000 -to 00:01:25.000 -vf scale=640:-1 -b:v 2666K -c:v libvpx -b:a 64K -c:a libvorbis -sn Ergo_Proxy_E16_00-01-13.webm

Since nothing is working, the guy on /wsg/ just told me to go to /g/. I then went to /g/, but the people there just told me to come here to /wsr/.
>>
On recommendation from this Google result…
>https://netheadaches.wordpress.com/2007/11/08/error-while-opening-codec-for-output-stream-01-maybe-incorrect-parameters-such-as-bit_rate-rate-width-or-height/
… I entered the following command…
>ffmpeg -i ./Ergo\ Proxy\ -\ 16\ NLT-Release.mkv -ss 00:01:13.000 -to 00:01:25.000 -vf scale=640:-1 -b:v 618K -c:v libvpx -ar 22050 -b:a 64K -c:a libvorbis -f webm -pass 1 -sn /dev/null
… but still got the same error.
>>
Do your commands work on other videos as sources or is it just this video?
>>
>>45385
I forgot to mention, I did download a different copy of the same video, from a different source and in a different resolution, and attempt most of these same commands on it. They all produced the same error.

>ffmpeg -i ./\[Golo\]\ Ergo\ Proxy\ -\ 16\ \[BD\]\[1920x1080\]\[9CD04FE9\].mkv -ss 00:01:14.000 -to 00:01:26.000 -vf scale=640:-1 -b:v 618K -c:v libvpx -b:a 64K -c:a libvorbis -f webm -pass 1 -sn /dev/null
>>
>>45385
However, I've just gone into a different folder and entered the following command…
>ffmpeg -i ./Goodfellas.1990.720p.BrRip.264.YIFY.mp4 -ss 00:40:16.500 -to 00:40:57.000 -vf scale=640:-1 -b:v 745K -c:v libvpx -b:a 64K -c:a libvorbis -f webm -pass 1 -sn /dev/null
… and it is now chugging away to make me the desired webm, with no errors. So now I'm just doubly confused.
>>
>>45385
Actually wait, hold on…. No, something's definitely wrong, here. It's not actually making the webm. It's stuck at frame zero.
>>
Okay, so I removed the codex declarations, on the advice of someone from /g/, and the error went away and I was successfully able to create a webm… but when I tried to post the webm to /wsg/, it said, "Bad video stream. Only VP8 is supported." What did I do wrong?

Here were the commands I used.
>ffmpeg -i ./Ergo\ Proxy\ -\ 16\ NLT-Release.mkv -ss 00:01:13.000 -to 00:01:24.500 -vf scale=640:-1 -b:v 2785K -b:a 64K -pass 1 -sn ErgoProxy_E16_00-01-13.webm
>ffmpeg -i ./Ergo\ Proxy\ -\ 16\ NLT-Release.mkv -ss 00:01:13.000 -to 00:01:24.500 -vf scale=640:-1 -b:v 2785K -b:a 64K -pass 2 -sn ErgoProxy_E16_00-01-13.webm
>>
>>45410
Also, there were two bizarre issues with the resulting webm: firstly, the metadata had the name of the original video file instead of the output filename I specified, and secondly, the filesize was unusually small. Based on the bitrate and length, the filesize should have been 4.0 MB, but instead it was about 2.2 MB. I also thought the video quality looked somewhat poor.
>>
>>45410
That guy on /g/ knows nothing. Although WebM is a container, it's also kind of a declaration of what you'll use. You have to put the -c:v libvpx back in.
4chan doesn't like h.264 in WebM containers.
>>
>>45412
You're right, it seems.

This does NOT give the error, but the result cannot be posted to 4chan, because, "Only VP8 is supported."
>ffmpeg -i ./Ergo\ Proxy\ -\ 16\ NLT-Release.mkv -ss 00:01:13.000 -to 00:01:24.500 -vf scale=640:-1 -b:v 2785K -b:a 64K -pass 1 -sn ErgoProxy_E16_00-01-13.webm

This does NOT give the error, but the result cannot be posted to 4chan, because, "Only Vorbis is supported."
>ffmpeg -i ./Ergo\ Proxy\ -\ 16\ NLT-Release.mkv -ss 00:01:13.000 -to 00:01:24.500 -vf scale=640:-1 -c:v libvpx -b:v 2785K -b:a 64K -pass 1 -sn ErgoProxy_E16_00-01-13.webm

This DOES give the error, and fails to produce a webm at all.
>ffmpeg -i ./Ergo\ Proxy\ -\ 16\ NLT-Release.mkv -ss 00:01:13.000 -to 00:01:24.500 -vf scale=640:-1 -c:v libvpx -b:v 2785K -c:a -libvorbis -b:a 64K -pass 1 -sn ErgoProxy_E16_00-01-13.webm

So apparently the problem is with libvorbis? Have I successfully diagnosed where the issue is?
>>
I did it! Thanks, /wsr/.
>>>/wsg/926643

All I had to do was remove the "-b:a" part.
>ffmpeg -i ./Ergo\ Proxy\ -\ 16\ NLT-Release.mkv -ss 00:01:13.000 -to 00:01:24.500 -vf scale=640:-1 -b:v 2849K -c:v libvpx -c:a libvorbis -pass 1 -sn ErgoProxy_E16_00-01-13.webm
>>
>>45424
You weren't supplying enough bandwidth for your number of audio channels.

You can keep your low audio bitrate if you reduce the number of channels down to 2 or less. Add -ac 2 to reduce the number of channels to 2.

By removing the audio bitrate setting it defaulted to a higher value, which was enough for the number of channels.
Thread replies: 13
Thread images: 2
Thread DB ID: 487862



[Boards: 3 / a / aco / adv / an / asp / b / biz / c / cgl / ck / cm / co / d / diy / e / fa / fit / g / gd / gif / h / hc / his / hm / hr / i / ic / int / jp / k / lgbt / lit / m / mlp / mu / n / news / o / out / p / po / pol / qa / qst / r / r9k / s / s4s / sci / soc / sp / t / tg / toy / trash / trv / tv / u / v / vg / vip /vp / vr / w / wg / wsg / wsr / x / y] [Search | Home]

[Boards: 3 / a / aco / adv / an / asp / b / biz / c / cgl / ck / cm / co / d / diy / e / fa / fit / g / gd / gif / h / hc / his / hm / hr / i / ic / int / jp / k / lgbt / lit / m / mlp / mu / n / news / o / out / p / po / pol / qa / qst / r / r9k / s / s4s / sci / soc / sp / t / tg / toy / trash / trv / tv / u / v / vg / vip /vp / vr / w / wg / wsg / wsr / x / y] [Search | Home]

All trademarks and copyrights on this page are owned by their respective parties. Images uploaded are the responsibility of the Poster. Comments are owned by the Poster.
This is a 4chan archive - all of the shown content originated from that site. This means that 4Archive shows their content, archived. If you need information for a Poster - contact them.
If a post contains personal/copyrighted/illegal content, then use the post's [Report] link! If a post is not removed within 24h contact me at [email protected] with the post's information.